CVE-2025-53003

High

Description

The Janssen Project is an open-source identity and access management (IAM) platform. Prior to version 1.8.0, the Config API returns results without scope verification. This has a large internal surface attack area that exposes all sorts of information from the IDP including clients, users, scripts ..etc. This issue has been patched in version 1.8.0. A workaround for this vulnerability involves users forking and building the config api, patching it in their system following commit 92eea4d.

SeverityHigh
CVSS8.2
Exploit probability—
ProductIo.jans:jans-config-api-server
PublishedJul 1, 2025
First seenJul 1, 2025

How to fix

Update
  • io.jans:jans-config-api-server1.8.0 or later

Affected products

ProductAffected versionsFixed in
io.jans:jans-config-api-serverMavenv < 1.8.01.8.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.