CVE-2025-5302

High

Description

A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issue is resolved in version 0.12.38.

SeverityHigh
CVSS8.6
Exploit probability—
ProductLlama-index-core
PublishedAug 25, 2025
First seenAug 25, 2025
Weakness typeCWE-674CWE-674

How to fix

Update
  • llama-index-core0.12.38 or later

Affected products

ProductAffected versionsFixed in
llama-index-corePyPIv < 0.12.380.12.38

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.