CVE-2025-53099

High

Description

Sentry is a developer-first error tracking and performance monitoring tool. Prior to version 25.5.0, an attacker with a malicious OAuth application registered with Sentry can take advantage of a race condition and improper handling of authorization code within Sentry to maintain persistence to a user's account. With a specially timed requests and redirect flows, an attacker could generate multiple authorization codes that could be used to exchange for access and refresh tokens. This was possible even after de-authorizing the particular application. This issue has been patched in version 25.5.0. Self-hosted Sentry users should upgrade to version 25.5.0 or higher. Sentry SaaS users do not need to take any action.

SeverityHigh
CVSS7.5
Exploit probability—
ProductSentry
PublishedJul 1, 2025
First seenJul 1, 2025
Weakness typeCWE-288CWE-288

How to fix

Update
  • sentry sentry25.5.0 or later

Affected products

ProductAffected versionsFixed in
sentry sentryv < 25.5.025.5.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.