CVE-2025-53121
Description
Multiple stored XSS were found on different nodes with unsanitized parameters in OpenMNS Horizon 33.0.8 and versions earlier than 33.1.6 on multiple platforms that allow an attacker to store on database and then inject HTML and/or Javascript on the page. The solution is to upgrade to Horizon 33.1.6, 33.1.7 or Meridian 2024.2.6, 2024.2.7 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Fábio Tomé for reporting this issue.
How to fix
- The OpenNMS Group Horizon33.1.6, 33.1.7 or later
- The OpenNMS Group Meridian2024.2.6, 2024.2.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| The OpenNMS Group Horizon | 33.0.8 ≤ v < 33.1.6, 33.1.7 | 33.1.6, 33.1.7 |
| The OpenNMS Group Meridian | 2024.1.4 ≤ v < 2024.2.6, 2024.2.7, 2023.1.20 ≤ v < 2024.2.6, 2024.2.7 | 2024.2.6, 2024.2.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.