CVE-2025-53122
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in OpenNMS Horizon and Meridian applications allows SQL Injection. Users should upgrade to Meridian 2024.2.6 or newer, or Horizon 33.16 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
How to fix
- The OpenNMS Group Horizon33.1.6, 33.1.7 or later
- The OpenNMS Group Meridian2024.2.6, 2024.2.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| The OpenNMS Group Horizon | 25.2.1 ≤ v < 33.1.6, 33.1.7, 33.0.8 ≤ v < 33.1.6, 33.1.7 | 33.1.6, 33.1.7 |
| The OpenNMS Group Meridian | 2024.1.0 ≤ v < 2024.2.6, 2024.2.7 | 2024.2.6, 2024.2.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.