CVE-2025-53354

Medium

Description

NiceGUI is a Python-based UI framework. Versions 2.24.2 and below are at risk for Cross-Site Scripting (XSS) when developers render unescaped user input into the DOM using ui.html(). NiceGUI did not enforce HTML or JavaScript sanitization, so applications that directly combine components like ui.input() with ui.html() or ui.chat_message with HTML content without escaping may allow attackers to execute arbitrary JavaScript in the user’s browser. Applications that do not pass untrusted input into ui.html() are not affected. This issue is fixed in version 3.0.0.

SeverityMedium
CVSS6.1
Exploit probability—
ProductNicegui
PublishedOct 3, 2025
First seenOct 3, 2025

How to fix

Update
  • nicegui3.0.0 or later

Affected products

ProductAffected versionsFixed in
niceguiPyPIv < 3.0.03.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.