CVE-2025-53606
Critical
Description
Deserialization of Untrusted Data vulnerability in Apache Seata (incubating). This issue affects Apache Seata (incubating): 2.4.0. Users are recommended to upgrade to version 2.5.0, which fixes the issue.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Apache Seata
PublishedAug 8, 2025
First seenAug 8, 2025
Weakness typeCWE-502Deserialization of untrusted data
How to fix
Update
- org.apache.seata:seata-serializer-fury2.5.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache seata | 2.4.0 | — |
| org.apache.seata:seata-serializer-furyMaven | 2.4.0 ≤ v < 2.5.0 | 2.5.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.