CVE-2025-53626
Medium
Description
pdfme is a TypeScript-based PDF generator and React-based UI. The expression evaluation feature in pdfme 5.2.0 to 5.4.0 contains critical vulnerabilities allowing sandbox escape leading to XSS and prototype pollution attacks. This vulnerability is fixed in 5.4.1.
SeverityMedium
CVSS6.1
Exploit probability26. percentile0.3%
Product@pdfme/common
PublishedJul 10, 2025
First seenJul 10, 2025
How to fix
Update
- @pdfme/common5.4.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| @pdfme/commonnpm | 5.2.0 ≤ v < 5.4.1 | 5.4.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.