CVE-2025-53648
Medium
Description
SQL misconfiguration in the Gravitino UI, in versions 1.0.0 and below, can allow a malicious user to read or truncate files. Users are recommended to upgrade to version 1.0.0, which fixes this issue.
SeverityMedium
CVSS5.4
Exploit probability—
Product
Apache Gravitino
PublishedJun 30, 2026
First seenJun 30, 2026
Weakness typeCWE-89SQL injection
How to fix
Update
- apache gravitino1.0.0 or later
- org.apache.gravitino:catalog-jdbc-common1.0.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache gravitino | 0.5.0 ≤ v < 1.0.0 | 1.0.0 |
| org.apache.gravitino:catalog-jdbc-commonMaven | 0.5.0 ≤ v < 1.0.0 | 1.0.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.