CVE-2025-53895
Description
ZITADEL is an open source identity management system. Starting in version 2.53.0 and prior to versions 4.0.0-rc.2, 3.3.2, 2.71.13, and 2.70.14, vulnerability in ZITADEL's session management API allows any authenticated user to update a session if they know its ID, due to a missing permission check. This flaw enables session hijacking, allowing an attacker to impersonate another user and access sensitive resources. Versions prior to `2.53.0` are not affected, as they required the session token for updates. Versions 4.0.0-rc.2, 3.3.2, 2.71.13, and 2.70.14 fix the issue.
How to fix
- zitadel zitadel2.70.14, 2.71.13, 3.3.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| zitadel zitadel | 2.53.0 ≤ v < 2.70.14, 2.71.0 ≤ v < 2.71.13, 3.0.0 ≤ v < 3.3.1, 4.0.0 | 2.70.14, 2.71.13, 3.3.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.