CVE-2025-54057
Medium
Description
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache SkyWalking. This issue affects Apache SkyWalking: <= 10.2.0. Users are recommended to upgrade to version 10.3.0, which fixes the issue.
SeverityMedium
CVSS6.1
Exploit probability—
Product
Apache Skywalking
PublishedNov 27, 2025
First seenNov 27, 2025
Weakness typeCWE-80CWE-80
How to fix
Update
- apache skywalking10.3.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache skywalking | v < 10.3.0 | 10.3.0 |
| org.apache.skywalking:apm-webappMaven | v ≤ 10.1.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.