CVE-2025-54068
Description
Livewire is a full-stack framework for Laravel. In Livewire v3 up to and including v3.6.3, a vulnerability allows unauthenticated attackers to achieve remote command execution in specific scenarios. The issue stems from how certain component property updates are hydrated. This vulnerability is unique to Livewire v3 and does not affect prior major versions. Exploitation requires a component to be mounted and configured in a particular way, but does not require authentication or user interaction. This issue has been patched in Livewire v3.6.4. All users are strongly encouraged to upgrade to this version or later as soon as possible. No known workarounds are available.
How to fix
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
CISA due date: Apr 3, 2026- laravel livewire3.6.4 or later
- livewire/livewire3.6.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| laravel livewire | 3.0.0 ≤ v < 3.6.4 | 3.6.4 |
| livewire/livewirePackagist | 3.0.0-beta.1 ≤ v < 3.6.4 | 3.6.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.