CVE-2025-54370
Description
PhpOffice/PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to versions 1.30.0, 2.1.12, 2.4.0, 3.10.0, and 5.0.0, SSRF can occur when a processed HTML document is read and displayed in the browser. The vulnerability lies in the setPath method of the PhpOffice\PhpSpreadsheet\Worksheet\Drawing class, where a crafted string from the user is passed to the HTML reader. This issue has been patched in versions 1.30.0, 2.1.12, 2.4.0, 3.10.0, and 5.0.0.
How to fix
- phpoffice/phpspreadsheet1.30.0, 2.1.12, 2.4.0, 3.10.0, 5.0.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| phpoffice/phpspreadsheetPackagist | v < 1.30.0, 2.0.0 ≤ v < 2.1.12, 2.2.0 ≤ v < 2.4.0, 3.0.0 ≤ v < 3.10.0, 4.0.0 ≤ v < 5.0.0 | 1.30.0, 2.1.12, 2.4.0, 3.10.0, 5.0.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.