CVE-2025-54417
Description
Craft is a platform for creating digital experiences. Versions 4.13.8 through 4.16.2 and 5.5.8 through 5.8.3 contain a vulnerability that can bypass CVE-2025-23209: "Craft CMS has a potential RCE with a compromised security key". To exploit this vulnerability, the project must meet these requirements: have a compromised security key and create an arbitrary file in Craft's /storage/backups folder. With those criteria in place, attackers could create a specific, malicious request to the /updater/restore-db endpoint and execute CLI commands remotely. This issue is fixed in versions 4.16.3 and 5.8.4.
How to fix
- craftcms craft_cms4.16.3, 5.8.4 or later
- craftcms/cms4.16.3, 5.8.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| craftcms craft_cms | 4.13.8 ≤ v < 4.16.3, 5.5.8 ≤ v < 5.8.4 | 4.16.3, 5.8.4 |
| craftcms/cmsPackagist | 4.13.8 ≤ v < 4.16.3, 5.5.8 ≤ v < 5.8.4 | 4.16.3, 5.8.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.