CVE-2025-54418

Critical

Description

CodeIgniter is a PHP full-stack web framework. A command injection vulnerability present in versions prior to 4.6.2 affects applications that use the ImageMagick handler for image processing (`imagick` as the image library) and either allow file uploads with user-controlled filenames and process uploaded images using the `resize()` method or use the `text()` method with user-controlled text content or options. An attacker can upload a file with a malicious filename containing shell metacharacters that get executed when the image is processed or provide malicious text content or options that get executed when adding text to images Users should upgrade to v4.6.2 or later to receive a patch. As a workaround, switch to the GD image handler (`gd`, the default handler), which is not affected by either vulnerability. For file upload scenarios, instead of using user-provided filenames, generate random names to eliminate the attack vector with `getRandomName()` when using the `move()` method, or use the `store()` method, which automatically generates safe filenames. For text operations, if one must use ImageMagick with user-controlled text, sanitize the input to only allow safe characters and validate/restrict text options.

SeverityCritical
CVSS9.8
Exploit probability—
ProductCodeigniter
PublishedJul 28, 2025
First seenJul 28, 2025

How to fix

Update
  • codeigniter codeigniter4.6.2 or later
  • codeigniter4/framework4.6.2 or later

Affected products

ProductAffected versionsFixed in
codeigniter codeigniter4.0.0 ≤ v < 4.6.24.6.2
codeigniter4/frameworkPackagistv < 4.6.24.6.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.