CVE-2025-54419
Description
A SAML library not dependent on any frameworks that runs in Node. In version 5.0.1, Node-SAML loads the assertion from the (unsigned) original response document. This is different than the parts that are verified when checking signature. This allows an attacker to modify authentication details within a valid SAML assertion. For example, in one attack it is possible to remove any character from the SAML assertion username. To conduct the attack an attacker would need a validly signed document from the identity provider (IdP). This is fixed in version 5.1.0.
How to fix
- @node-saml/node-saml5.1.0 or later
- @node-saml/passport-saml5.1.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| @node-saml/node-samlnpm | v < 5.1.0 | 5.1.0 |
| passport-samlnpm | v ≤ 3.2.4 | — |
| @node-saml/passport-samlnpm | v < 5.1.0 | 5.1.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.