CVE-2025-54574
Critical
Description
Squid is a caching proxy for the Web. In versions 6.3 and below, Squid is vulnerable to a heap buffer overflow and possible remote code execution attack when processing URN due to incorrect buffer management. This has been fixed in version 6.4. To work around this issue, disable URN access permissions.
SeverityCritical
CVSS9.3
Exploit probability—
ProductSquid
PublishedAug 1, 2025
First seenAug 1, 2025
Weakness typeCWE-122CWE-122
How to fix
Update
- squid-cache squid6.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| squid-cache squid | v < 6.4 | 6.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.