CVE-2025-5472

Medium

Description

The JSONReader in run-llama/llama_index versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled recursive JSON parsing. This vulnerability allows attackers to trigger a Denial of Service (DoS) by submitting deeply nested JSON structures, leading to a RecursionError and crashing applications. The root cause is the unsafe recursive traversal design and lack of depth validation, which makes the JSONReader susceptible to stack overflow when processing deeply nested JSON. This impacts the availability of services, making them unreliable and disrupting workflows. The issue is resolved in version 0.12.38.

SeverityMedium
CVSS6.5
Exploit probability—
ProductLlamaindex
PublishedJul 7, 2025
First seenJul 7, 2025
Weakness typeCWE-674CWE-674

How to fix

Update
  • llamaindex llamaindex0.12.38 or later
  • llama-index-core0.12.38 or later
  • llama-index0.12.38 or later

Affected products

ProductAffected versionsFixed in
llamaindex llamaindex0.12.28 ≤ v < 0.12.380.12.38
llama-index-corePyPIv < 0.12.380.12.38
llama-indexPyPI0.12.28 ≤ v < 0.12.380.12.38

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.