CVE-2025-54988
Description
Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. An attacker may be able to read sensitive data or trigger malicious requests to internal resources or third-party servers. Note that the tika-parser-pdf-module is used as a dependency in several Tika packages including at least: tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc and tika-server-standard. Users are recommended to upgrade to version 3.2.2, which fixes this issue.
How to fix
- apache tika3.2.2 or later
- org.apache.tika:tika-parser-pdf-module3.2.2 or later
- org.apache.tika:tika-parsers2.0.0-ALPHA or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tika | 1.13 ≤ v < 3.2.2 | 3.2.2 |
| org.apache.tika:tika-parser-pdf-moduleMaven | 1.13 ≤ v < 3.2.2 | 3.2.2 |
| org.apache.tika:tika-parsersMaven | 1.13 ≤ v < 2.0.0-ALPHA | 2.0.0-ALPHA |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.