CVE-2025-54997

Critical

Description

OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. In versions 2.3.1 and below, some OpenBao deployments intentionally limit privileged API operators from executing system code or making network connections. However, these operators can bypass both restrictions through the audit subsystem by manipulating log prefixes. This allows unauthorized code execution and network access that violates the intended security model. This issue is fixed in version 2.3.2. To workaround, users can block access to sys/audit/* endpoints using explicit deny policies, but root operators cannot be restricted this way.

SeverityCritical
CVSS9.1
Exploit probability—
ProductOpenbao
PublishedAug 9, 2025
First seenAug 9, 2025

How to fix

Update
  • openbao openbao2.3.2 or later
  • github.com/openbao/openbao2.3.2, 0.0.0-20250806194004-a14053c9679d or later

Affected products

ProductAffected versionsFixed in
openbao openbaov < 2.3.22.3.2
github.com/openbao/openbaoGo0.1.0 ≤ v < 2.3.2, v < 0.0.0-20250806194004-a14053c9679d, 0.1.0 ≤ v2.3.2, 0.0.0-20250806194004-a14053c9679d

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.