CVE-2025-55017
Critical
Description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 2.0.0 before 2.0.6, from 1.0.0 before 1.3.6. Users are recommended to upgrade to version 1.3.6 and 2.0.6, which fixes the issue.
SeverityCritical
CVSS9.1
Exploit probability—
ProductOrg.apache.iotdb:iotdb-server
PublishedJun 26, 2026
First seenJun 26, 2026
Weakness typeCWE-22Path traversal
How to fix
Update
- org.apache.iotdb:iotdb-server2.0.6, 1.3.6 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| org.apache.iotdb:iotdb-serverMaven | 2.0.0 ≤ v < 2.0.6, 1.0.0 ≤ v < 1.3.6 | 2.0.6, 1.3.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.