CVE-2025-55157

High

Description

Vim is an open source, command line text editor. In versions from 9.1.1231 to before 9.1.1400, When processing nested tuples in Vim script, an error during evaluation can trigger a use-after-free in Vim’s internal tuple reference management. Specifically, the tuple_unref() function may access already freed memory due to improper lifetime handling, leading to memory corruption. The exploit requires direct user interaction, as the script must be explicitly executed within Vim. This issue has been patched in version 9.1.1400.

SeverityHigh
CVSS8.8
Exploit probability—
ProductVim
PublishedAug 11, 2025
First seenAug 11, 2025

How to fix

Update
  • vim vim9.1.1400 or later

Affected products

ProductAffected versionsFixed in
vim vim9.1.1231 ≤ v < 9.1.14009.1.1400

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.