CVE-2025-55163
Description
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.124.Final and 4.2.4.Final, Netty is vulnerable to MadeYouReset DDoS. This is a logical vulnerability in the HTTP/2 protocol, that uses malformed HTTP/2 control frames in order to break the max concurrent streams limit - which results in resource exhaustion and distributed denial of service. This issue has been patched in versions 4.1.124.Final and 4.2.4.Final.
How to fix
- netty netty4.1.124, 4.2.4 or later
- io.netty:netty-codec-http24.2.4.Final, 4.1.124.Final or later
- io.grpc:grpc-netty-shaded1.75.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| netty netty | v < 4.1.124, 4.2.0 ≤ v < 4.2.4 | 4.1.124, 4.2.4 |
| io.netty:netty-codec-http2Maven | 4.2.0.Alpha1 ≤ v < 4.2.4.Final, v < 4.1.124.Final | 4.2.4.Final, 4.1.124.Final |
| io.grpc:grpc-netty-shadedMaven | v < 1.75.0 | 1.75.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.