CVE-2025-55173
Description
Next.js is a React framework for building full-stack web applications. In versions before 14.2.31 and from 15.0.0 to before 15.4.5, Next.js Image Optimization is vulnerable to content injection. The issue allowed attacker-controlled external image sources to trigger file downloads with arbitrary content and filenames under specific configurations. This behavior could be abused for phishing or malicious file delivery. This vulnerability has been fixed in Next.js versions 14.2.31 and 15.4.5.
How to fix
- vercel next.js14.2.31, 15.4.5 or later
- next14.2.31, 15.4.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vercel next.js | v < 14.2.31, 15.0.0 ≤ v < 15.4.5 | 14.2.31, 15.4.5 |
| nextnpm | 0.9.9 ≤ v < 14.2.31, 15.0.0 ≤ v < 15.4.5 | 14.2.31, 15.4.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.