CVE-2025-55213

Critical

Description

OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.9.3 to v1.9.4 ( openfga-0.2.40 <= Helm chart <= openfga-0.2.41, v1.9.3 <= docker <= v.1.9.4) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This vulnerability is fixed in 1.9.5.

SeverityCritical
CVSS9.8
Exploit probability—
ProductOpenfga Helm Charts
PublishedAug 18, 2025
First seenAug 18, 2025

How to fix

Update
  • openfga helm_charts0.2.42 or later
  • openfga openfga1.9.5 or later
  • github.com/openfga/openfga1.9.5 or later

Affected products

ProductAffected versionsFixed in
openfga helm_charts0.2.40 ≤ v < 0.2.420.2.42
openfga openfga1.9.3 ≤ v < 1.9.51.9.5
github.com/openfga/openfgaGo1.9.3 ≤ v < 1.9.51.9.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.