CVE-2025-55283
Critical
Description
aiven-db-migrate is an Aiven database migration tool. Prior to 1.0.7, there is a privilege escalation vulnerability that allows elevation to superuser inside PostgreSQL databases during a migration from an untrusted source server. The vulnerability stems from psql executing commands embedded in a dump from the source server. This vulnerability is fixed in 1.0.7.
SeverityCritical
CVSS9.1
Exploit probability50. percentile0.6%
ProductAiven-db-migrate
PublishedAug 18, 2025
First seenAug 18, 2025
Weakness typeCWE-77Command injection
How to fix
Update
- aiven aiven-db-migrate1.0.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| aiven aiven-db-migrate | v < 1.0.7 | 1.0.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.