CVE-2025-55668
Medium
Description
Session Fixation vulnerability in Apache Tomcat via rewrite valve. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.
SeverityMedium
CVSS6.5
Exploit probability—
Product
Apache Tomcat
PublishedAug 13, 2025
First seenAug 13, 2025
Weakness typeCWE-384CWE-384
How to fix
Update
- apache tomcat9.0.106, 10.1.42, 11.0.8 or later
- org.apache.tomcat:tomcat-catalina11.0.8, 10.1.42, 9.0.106 or later
- org.apache.tomcat.embed:tomcat-embed-core11.0.8, 10.1.42, 9.0.106 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tomcat | 9.0.1 ≤ v < 9.0.106, 10.0.0 ≤ v < 10.1.42, 11.0.0 ≤ v < 11.0.8, 9.0.0 | 9.0.106, 10.1.42, 11.0.8 |
| org.apache.tomcat:tomcat-catalinaMaven | 11.0.0-M1 ≤ v < 11.0.8, 10.1.0-M1 ≤ v < 10.1.42, 9.0.0.M1 ≤ v < 9.0.106 | 11.0.8, 10.1.42, 9.0.106 |
| org.apache.tomcat.embed:tomcat-embed-coreMaven | 11.0.0-M1 ≤ v < 11.0.8, 10.1.0-M1 ≤ v < 10.1.42, 9.0.0.M1 ≤ v < 9.0.106 | 11.0.8, 10.1.42, 9.0.106 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.