CVE-2025-55673

Medium

Description

When a guest user accesses a chart in Apache Superset, the API response from the /chart/data endpoint includes a query field in its payload. This field contains the underlying query, which improperly discloses database schema information, such as table names, to the low-privileged guest user. This issue affects Apache Superset: before 4.1.3. Users are recommended to upgrade to version 4.1.3, which fixes the issue.

SeverityMedium
CVSS4.3
Exploit probability—
ProductApache Superset
PublishedAug 14, 2025
First seenAug 14, 2025

How to fix

Update
  • apache superset4.1.3 or later
  • apache-superset4.1.3.post1 or later

Affected products

ProductAffected versionsFixed in
apache supersetv < 4.1.34.1.3
apache-supersetPyPIv < 4.1.3.post14.1.3.post1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-55673 · Apache Superset · Dark Radar