CVE-2025-55675

Medium

Description

Apache Superset contains an improper access control vulnerability in its /explore endpoint. A missing authorization check allows an authenticated user to discover metadata about datasources they do not have permission to access. By iterating through the datasource_id in the URL, an attacker can enumerate and confirm the existence and names of protected datasources, leading to sensitive information disclosure. This issue affects Apache Superset: before 5.0.0. Users are recommended to upgrade to version 5.0.0, which fixes the issue.

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache Superset
PublishedAug 14, 2025
First seenAug 14, 2025
Weakness typeCWE-285CWE-285

How to fix

Update
  • apache superset5.0.0 or later
  • apache-superset5.0.0 or later

Affected products

ProductAffected versionsFixed in
apache supersetv < 5.0.05.0.0
apache-supersetPyPIv < 5.0.05.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.