CVE-2025-55754

Critical

Description

Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.40 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.

SeverityCritical
CVSS9.6
Exploit probability—
ProductApache Tomcat
PublishedOct 27, 2025
First seenOct 27, 2025
Weakness typeCWE-150CWE-150

How to fix

Update
  • apache tomcat9.0.109, 10.0.27, 10.1.45, 11.0.11 or later
  • org.apache.tomcat:tomcat11.0.11, 10.1.45, 9.0.109 or later
  • org.apache.tomcat.embed:tomcat-embed-core11.0.11, 10.1.45, 9.0.109 or later
  • org.apache.tomcat:tomcat-catalina11.0.11, 10.1.45, 9.0.109 or later

Affected products

ProductAffected versionsFixed in
apache tomcat8.5.60 ≤ v ≤ 8.5.100, 9.0.40 ≤ v < 9.0.109, 10.0.0 ≤ v < 10.0.27, 10.1.0 ≤ v < 10.1.45, 11.0.0 ≤ v < 11.0.119.0.109, 10.0.27, 10.1.45, 11.0.11
org.apache.tomcat:tomcatMaven11.0.0-M1 ≤ v < 11.0.11, 10.1.0-M1 ≤ v < 10.1.45, 9.0.40 ≤ v < 9.0.109, 8.5.60 ≤ v ≤ 8.5.10011.0.11, 10.1.45, 9.0.109
org.apache.tomcat.embed:tomcat-embed-coreMaven11.0.0-M1 ≤ v < 11.0.11, 10.1.0-M1 ≤ v < 10.1.45, 9.0.40 ≤ v < 9.0.109, 8.5.60 ≤ v ≤ 8.5.10011.0.11, 10.1.45, 9.0.109
org.apache.tomcat:tomcat-catalinaMaven11.0.0-M1 ≤ v < 11.0.11, 10.1.0-M1 ≤ v < 10.1.45, 9.0.40 ≤ v < 9.0.109, 8.5.60 ≤ v ≤ 8.5.10011.0.11, 10.1.45, 9.0.109

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.