CVE-2025-57389
Medium
Description
A reflected cross-site scripting (XSS) vulnerability in the /admin/system/packages endpoint of Luci OpenWRT v18.06.2 allows attackers to execute arbitrary Javascript in the context of a user's browser via a crafted payload. This vulnerability was fixed in OpenWRT v19.07.0.
SeverityMedium
CVSS5.4
Exploit probability—
ProductLuci
PublishedOct 1, 2025
First seenOct 1, 2025
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- OpenWRT Luci19.07.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| OpenWRT Luci | 18.06.2 | 19.07.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.