CVE-2025-57752
Description
Next.js is a React framework for building full-stack web applications. In versions before 14.2.31 and from 15.0.0 to before 15.4.5, Next.js Image Optimization API routes are affected by cache key confusion. When images returned from API routes vary based on request headers (such as Cookie or Authorization), these responses could be incorrectly cached and served to unauthorized users due to a cache key confusion bug. This vulnerability has been fixed in Next.js versions 14.2.31 and 15.4.5. All users are encouraged to upgrade if they use API routes to serve images that depend on request headers and have image optimization enabled.
How to fix
- vercel next.js14.2.31, 15.4.5 or later
- next14.2.31, 15.4.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vercel next.js | v < 14.2.31, 15.0.0 ≤ v < 15.4.5 | 14.2.31, 15.4.5 |
| nextnpm | 0.9.9 ≤ v < 14.2.31, 15.0.0 ≤ v < 15.4.5 | 14.2.31, 15.4.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.