CVE-2025-57773

Critical

Description

DataEase is an open source business intelligence and data visualization tool. Prior to version 2.10.12, because DB2 parameters are not filtered, a JNDI injection attack can be directly launched. JNDI triggers an AspectJWeaver deserialization attack, writing to various files. This vulnerability requires commons-collections 4.x and aspectjweaver-1.9.22.jar. The vulnerability has been fixed in version 2.10.12.

SeverityCritical
CVSS9.8
Exploit probability—
ProductDataease
PublishedAug 25, 2025
First seenAug 25, 2025

How to fix

Update
  • dataease dataease2.10.12 or later

Affected products

ProductAffected versionsFixed in
dataease dataeasev < 2.10.122.10.12

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.