CVE-2025-58054
Low
Description
Discourse is an open-source community discussion platform. Versions 3.5.0 and below are vulnerable to XSS attacks through parsing and rendering of chat channel titles and chat thread titles via the quote message functionality when using the rich text editor. This issue is fixed in version 3.5.1.
SeverityLow
CVSS3.5
Exploit probability—
Product
Discourse
PublishedOct 1, 2025
First seenOct 1, 2025
Weakness typeCWE-80CWE-80
How to fix
Update
- discourse discourse3.5.0, 3.6.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| discourse discourse | v < 3.5.0, v < 3.6.0, 3.6.0 | 3.5.0, 3.6.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.