CVE-2025-58064
Description
CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.
How to fix
- ckeditor546.0.3, 45.2.2 or later
- @ckeditor/ckeditor5-clipboard45.2.2, 46.0.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| ckeditor5npm | 46.0.0 ≤ v < 46.0.3, 44.2.0 ≤ v < 45.2.2 | 46.0.3, 45.2.2 |
| @ckeditor/ckeditor5-clipboardnpm | 44.2.0 ≤ v < 45.2.2, 46.0.0 ≤ v < 46.0.3 | 45.2.2, 46.0.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.