CVE-2025-58068

Critical

Description

Eventlet is a concurrent networking library for Python. Prior to version 0.40.3, the Eventlet WSGI parser is vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer sections. This vulnerability could enable attackers to, bypass front-end security controls, launch targeted attacks against active site users, and poison web caches. This problem has been patched in Eventlet 0.40.3 by dropping trailers which is a breaking change if a backend behind eventlet.wsgi proxy requires trailers. A workaround involves not using eventlet.wsgi facing untrusted clients.

SeverityCritical
CVSS9.1
Exploit probability—
ProductEventlet
PublishedAug 29, 2025
First seenAug 29, 2025
Weakness typeCWE-444CWE-444

How to fix

Update
  • eventlet eventlet0.40.3 or later
  • eventlet0.40.3 or later

Affected products

ProductAffected versionsFixed in
eventlet eventletv < 0.40.30.40.3
eventletPyPIv < 0.40.30.40.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-58068 · Eventlet · Dark Radar