CVE-2025-58157

High

Description

gnark is a zero-knowledge proof system framework. In version 0.12.0, there is a potential denial of service vulnerability when computing scalar multiplication is using the fake-GLV algorithm. This is because the algorithm didn't converge quickly enough for some of the inputs. This issue has been patched in version 0.13.0.

SeverityHigh
CVSS7.5
Exploit probability—
ProductConsensys Gnark
PublishedAug 29, 2025
First seenAug 29, 2025

How to fix

Update
  • github.com/consensys/gnark0.13.0 or later

Affected products

ProductAffected versionsFixed in
consensys gnark0.12.0—
github.com/consensys/gnarkGo0.12.0 ≤ v < 0.13.0, v < 0.13.00.13.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-58157 · Consensys Gnark · Dark Radar