CVE-2025-58177

Medium

Description

n8n is an open source workflow automation platform. From 1.24.0 to before 1.107.0, there is a stored cross-site scripting (XSS) vulnerability in @n8n/n8n-nodes-langchain.chatTrigger. An authorized user can configure the LangChain Chat Trigger node with malicious JavaScript in the initialMessages field and enable public access so that the payload is executed in the browser of any user who visits the resulting public chat URL. This can be used for phishing or to steal cookies or other sensitive data from users accessing the public chat link. The issue is fixed in version 1.107.0. Updating to 1.107.0 or later is recommended. As a workaround, the affected chatTrigger node can be disabled. No other workarounds are known.

SeverityMedium
CVSS5.4
Exploit probability—
ProductN8n
PublishedSep 15, 2025
First seenSep 15, 2025

How to fix

Update
  • n8n n8n1.107.0 or later
  • n8n1.107.0 or later

Affected products

ProductAffected versionsFixed in
n8n n8n1.24.0 ≤ v < 1.107.01.107.0
n8nnpm1.24.0 ≤ v < 1.107.01.107.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-58177 · N8n · Dark Radar