CVE-2025-58352

Medium

Description

Weblate is a web based localization tool. Versions lower than 5.13.1 contain a vulnerability that causes long session expiry during the second factor verification. The long session expiry could be used to circumvent rate limiting of the second factor. This issue is fixed in version 5.13.1.

SeverityMedium
CVSS6.5
Exploit probability—
ProductWeblate
PublishedSep 5, 2025
First seenSep 5, 2025
Weakness typeCWE-613CWE-613

How to fix

Update
  • weblate weblate5.13.1 or later
  • weblate5.13.1 or later

Affected products

ProductAffected versionsFixed in
weblate weblatev < 5.13.15.13.1
weblatePyPIv < 5.13.15.13.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.