CVE-2025-58439
High
Description
ERP is a free and open source Enterprise Resource Planning tool. In versions below 14.89.2 and 15.0.0 through 15.75.1, lack of validation of parameters left certain endpoints vulnerable to error-based SQL Injection. Some information like version could be retrieved. This issue is fixed in versions 14.89.2 and 15.76.0.
SeverityHigh
CVSS8.1
Exploit probability—
Product
Frappe Erpnext
PublishedSep 6, 2025
First seenSep 6, 2025
Weakness typeCWE-89SQL injection
How to fix
Update
- frappe erpnext14.89.2, 15.76.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| frappe erpnext | v < 14.89.2, 15.0.0 ≤ v < 15.76.0 | 14.89.2, 15.76.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.