CVE-2025-58457

Medium

Description

Improper permission check in ZooKeeper AdminServer lets authorized clients to run snapshot and restore command with insufficient permissions. This issue affects Apache ZooKeeper: from 3.9.0 before 3.9.4. Users are recommended to upgrade to version 3.9.4, which fixes the issue. The issue can be mitigated by disabling both commands (via admin.snapshot.enabled and admin.restore.enabled), disabling the whole AdminServer interface (via admin.enableServer), or ensuring that the root ACL does not provide open permissions. (Note that ZooKeeper ACLs are not recursive, so this does not impact operations on child nodes besides notifications from recursive watches.)

SeverityMedium
CVSS4.3
Exploit probability—
ProductApache Zookeeper
PublishedSep 24, 2025
First seenSep 24, 2025
Weakness typeCWE-280CWE-280

How to fix

Update
  • apache zookeeper3.9.4 or later
  • org.apache.zookeeper:zookeeper3.9.4 or later

Affected products

ProductAffected versionsFixed in
apache zookeeper3.9.0 ≤ v < 3.9.43.9.4
org.apache.zookeeper:zookeeperMaven3.9.0 ≤ v < 3.9.43.9.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.