CVE-2025-58782
Description
Deserialization of Untrusted Data vulnerability in Apache Jackrabbit Core and Apache Jackrabbit JCR Commons. This issue affects Apache Jackrabbit Core: from 1.0.0 through 2.22.1; Apache Jackrabbit JCR Commons: from 1.0.0 through 2.22.1. Deployments that accept JNDI URIs for JCR lookup from untrusted users allows them to inject malicious JNDI references, potentially leading to arbitrary code execution through deserialization of untrusted data. Users are recommended to upgrade to version 2.22.2. JCR lookup through JNDI has been disabled by default in 2.22.2. Users of this feature need to enable it explicitly and are adviced to review their use of JNDI URI for JCR lookup.
How to fix
- apache jackrabbit2.22.2 or later
- org.apache.jackrabbit:jackrabbit-core2.22.2 or later
- org.apache.jackrabbit:jackrabbit-jcr-commons2.22.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache jackrabbit | 1.0.0 ≤ v < 2.22.2 | 2.22.2 |
| org.apache.jackrabbit:jackrabbit-coreMaven | 1.0.0 ≤ v < 2.22.2 | 2.22.2 |
| org.apache.jackrabbit:jackrabbit-jcr-commonsMaven | 1.0.0 ≤ v < 2.22.2 | 2.22.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.