CVE-2025-5889
Description
A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.
How to fix
- brace-expansion2.0.2, 1.1.12, 3.0.1, 4.0.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| brace-expansionnpm | 2.0.0 ≤ v < 2.0.2, 1.0.0 ≤ v < 1.1.12, 3.0.0 ≤ v < 3.0.1, 4.0.0 ≤ v < 4.0.1 | 2.0.2, 1.1.12, 3.0.1, 4.0.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.