CVE-2025-59036
Description
Infrahub offers a central hub to manage data, templates, and playbooks. Prior to versiond 1.3.9 and 1.4.5, a bug in the authentication logic will cause API tokens that were deleted and/or expired to be considered valid. This means that any API token that is associated with an active user account can authenticate successfully. This issue is fixed in versions 1.3.9 and 1.4.5. As a workaround, users can delete or deactivate the account associated with a deleted API token to prevent that token from authenticating.
How to fix
- infrahub-server1.3.9, 1.4.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| infrahub-serverPyPI | v < 1.3.9, 1.4.0 ≤ v < 1.4.5 | 1.3.9, 1.4.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.