CVE-2025-59037
Description
DuckDB is an analytical in-process SQL database management system. On 08 September 2025, the DuckDB distribution for Node.js on npm was compromised with malware (along with several other packages). An attacker published new versions of four of DuckDB's packages that included malicious code to interfere with cryptocoin transactions* According to the npm statistics, nobody has downloaded these packages before they were deprecated. The packages and versions `@duckdb/[email protected]`, `@duckdb/[email protected]`, `[email protected]`, and `@duckdb/[email protected]` were affected. DuckDB immediately deprecated the specific versions, engaged npm support to delete the affected verions, and re-released the node packages with higher version numbers (1.3.4/1.30.0). Users may upgrade to versions 1.3.4, 1.30.0, or a higher version to protect themselves. As a workaround, they may also downgrade to 1.3.2 or 1.29.1.
How to fix
- duckdb1.3.4 or later
- @duckdb/node-api1.3.4-alpha.27 or later
- @duckdb/node-bindings1.3.4-alpha.27 or later
- @duckdb/duckdb-wasm1.30.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| duckdbnpm | 1.3.3 ≤ v < 1.3.4 | 1.3.4 |
| @duckdb/node-apinpm | 1.3.3 ≤ v < 1.3.4-alpha.27 | 1.3.4-alpha.27 |
| @duckdb/node-bindingsnpm | 1.3.3 ≤ v < 1.3.4-alpha.27 | 1.3.4-alpha.27 |
| @duckdb/duckdb-wasmnpm | 1.29.2 ≤ v < 1.30.0 | 1.30.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.