CVE-2025-59048

High

Description

OpenBao's AWS Plugin generates AWS access credentials based on IAM policies. Prior to version 0.1.1, the AWS Plugin is vulnerable to cross-account IAM role Impersonation in the AWS auth method. The vulnerability allows an IAM role from an untrusted AWS account to authenticate by impersonating a role with the same name in a trusted account, leading to unauthorized access. This impacts all users of the auth-aws plugin who operate in a multi-account AWS environment where IAM role names may not be unique across accounts. This vulnerability has been patched in version 0.1.1 of the auth-aws plugin. A workaround for this issue involves guaranteeing that IAM role names are unique across all AWS accounts that could potentially interact with your OpenBao environment, and to audit for any duplicate IAM roles.

SeverityHigh
CVSS8.1
Exploit probability—
ProductOpenbao Aws Plugin
PublishedOct 23, 2025
First seenOct 23, 2025

How to fix

Update
  • openbao aws_plugin0.1.1 or later
  • github.com/openbao/openbao-plugins0.1.1 or later

Affected products

ProductAffected versionsFixed in
openbao aws_pluginv < 0.1.10.1.1
github.com/openbao/openbao-pluginsGov < 0.1.1, No range specified0.1.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.