CVE-2025-59057
Description
React Router is a router for React. In @remix-run/react versions 1.15.0 through 2.17.0. and react-router versions 7.0.0 through 7.8.2, a XSS vulnerability exists in in React Router's meta()/<Meta> APIs in Framework Mode when generating script:ld+json tags which could allow arbitrary JavaScript execution during SSR if untrusted content is used to generate the tag. There is no impact if the application is being used in Declarative Mode (<BrowserRouter>) or Data Mode (createBrowserRouter/<RouterProvider>). This issue has been patched in @remix-run/react version 2.17.1 and react-router version 7.9.0.
How to fix
- react-router7.9.0 or later
- @remix-run/react2.17.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| shopify react-router | 7.0.0 ≤ v ≤ 7.8.2 | — |
| shopify remix-run\/react | 1.15.0 ≤ v ≤ 2.17.0 | — |
| react-routernpm | 7.0.0 ≤ v < 7.9.0 | 7.9.0 |
| @remix-run/reactnpm | 1.15.0 ≤ v < 2.17.1 | 2.17.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.