CVE-2025-59059

Critical

Description

Remote Code Execution Vulnerability in NashornScriptEngineCreator is reported in Apache Ranger versions <= 2.7.0. Users are recommended to upgrade to version 2.8.0, which fixes this issue.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Ranger
PublishedMar 3, 2026
First seenMar 3, 2026

How to fix

Update
  • apache ranger2.8.0 or later
  • org.apache.ranger:ranger-plugins-common2.8.0 or later

Affected products

ProductAffected versionsFixed in
apache rangerv < 2.8.02.8.0
org.apache.ranger:ranger-plugins-commonMavenv < 2.8.02.8.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.