CVE-2025-59060

Medium

Description

Hostname verification bypass issue in Apache Ranger NiFiRegistryClient is reported in Apache Ranger versions <= 2.7.0. Users are recommended to upgrade to version 2.8.0, which fixes this issue.

SeverityMedium
CVSS5.3
Exploit probability—
ProductApache Ranger
PublishedMar 3, 2026
First seenMar 3, 2026
Weakness typeCWE-297CWE-297

How to fix

Update
  • apache ranger2.8.0 or later
  • org.apache.ranger:ranger-nifi-registry-plugin2.8.0 or later

Affected products

ProductAffected versionsFixed in
apache rangerv < 2.8.02.8.0
org.apache.ranger:ranger-nifi-registry-pluginMavenv < 2.8.02.8.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.