CVE-2025-59163

Low

Description

vet is an open source software supply chain security tool. Versions 1.12.4 and below are vulnerable to a DNS rebinding attack due to lack of HTTP Host and Origin header validation. Data from the vet scan sqlite3 database may be exposed to remote attackers when vet is used as an MCP server in SSE mode with default ports through the sqlite3 query MCP tool. This issue is fixed in version 1.12.5.

SeverityLow
CVSS2.1
Exploit probability—
ProductGithub.com/safedep/vet
PublishedSep 29, 2025
First seenSep 29, 2025
Weakness typeCWE-350CWE-350

How to fix

Update
  • github.com/safedep/vet1.12.5 or later

Affected products

ProductAffected versionsFixed in
github.com/safedep/vetGov < 1.12.51.12.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-59163 · Github.com/safedep/vet · Dark Radar